Top CCNA Interview Questions and Answers -5

1. Which algorithm used by RIP?

RIP uses Bellman Ford algorithm.

2. Why RIP is inefficient on large network?

RIP is inefficient on large networks with slow wan link or on network with large number of router installed.

3. Explain RIP process.

In a RIP network, each router broadcast its entire RIP table to its neighboring routers every 30 second. When a router receives a neighbor’s RIP table, it uses the information provided to update its own routing table and then sends the updated table to its neighbors.

4. Explain load balancing in RIP.

If RIP finds more than one link with the same hop count to the same remote network, it will automatically perform a Round-Robin load balancing. RIP can perform load balancing for up to 6 equal cost link (By default is 4).

5. What is the range of load balancing in RIP?

Range of load balancing in RIP is 4 by default, but RIP can perform load balancing for up to 6 equal cost link.

6. What is differences between RIPv1 and RIPv2?

RIPv1 (Routing Information Protocol Version 1)
– It is Distance Vector Protocol.
– Interior Gateway Protocol.
– Maximum hop count limit is 15
– It is classful
– Broadcast Based
– Does not support VLSM (Variable Length Subnet Masking).
– There is no authentication.
– Does not support for Discontiguous Network
– Hello/Dead time – 30/180
– Broadcast based – RIPv1 sends routing update periodically every 30second as broadcast using destination IP address as limited broadcast IP address 255.255.255.255. Since the updates are sent using the destination IP address of limited broadcast IP address 255.255.255.255, every router need to process the routing update message (Whether they are running RIPv1 or not)

RIPv2 (Routing Information Protocol Version 2)
– It is Distance Vector Protocol.
– Interior Gateway Protocol.
– Maximum hop count limit is 15
– It is classless
– Use multicast 224.0.0.9
– Support VLSM (Variable Length Subnet Masking).
– Allow for MD5 authentication.
– Support for Discontiguous Network
– Hello/Dead time – 30/180
– RIPv2 routing updates are sent as multicast traffic at destination multicast address of 224.0.0.9. Multicast updates reduces the network traffic. The multicast routing updates also helps in reducing routing update message processing overhead in routers which are not running RIPv2. Only the routers running RIPv2 join to the multicast group 224.0.0.9. Other routers which are not running RIPv2 can simply filter the routing update packet at layer 2

7. What is pinhole congestion?

When two routes for the same destination have the same hop count in the RIP, this situation is known as Pinhole Congestion.

8. What is passive interface in RIP?

This command prevents RIP update broadcasts from being sent out a specified interface, yet that same interface can still receive RIP updates. Thus a RIP router with a passive interface will still learn about the network advertise by other router.

9. How to configure passive interface in RIP on particular interface?

Router#config t
Router(config)#router rip
Router(config-router)#network 192.168.20.0
Router(config-router)#passive-interface serial 0/0

10. How to configure passive interface in RIP on all interface?

We can configure all interfaces by using “passive-interface default” command and then individually ues the “no passive-interface” command on the interfaces we want updates to be sent out

Router#config t
Router(config)#router rip
Router(config-router)#network 192.168.20.0
Router(config-router)#network 192.168.30.0
Router(config-router)#passive-interface default
Router(config-router)#no passive-interface F0/0

11. How to configure passive interface in RIP when we used the neighbor command under the RIP process?

If you used the neighbor command under the RIP process, the router will send unicast updates as well as multicast updates. The passive interface command must be used disable Multicast/broadcast updates and allowing only unicast.

Router#config t
Router(config)#router rip
Router(config-router)#passive-interface S0/0/0
Router(config-router)#passive-interface S0/1/0
Router(config-router)#neighbor 192.168.20.1
Router(config-router)#neighbor 192.168.30.1

12. Explain RIP timers?

RIP uses four different type of timers

Route update timer (30 Second)

– Sets the interval (typically 30 seconds) between periodic routing updates in which the outer sends a complete copy of its routing table out to all neighbors.

Route invalid timer (180 Second)
– Determines the length of time that must elapse (180 seconds) before a router determines that a route has become invalid.If it hasn’t heard any updates about a particular route for that period.
– When that happens, the router will send out updates to all its neighbors letting them know that the route is invalid.

Hold-down timer (180 Second)
– This sets the amount of time during which routing information is suppressed.
– Routes will enter into the holddown state
– when an update packet is received that indicates the route is unreachable.
– This continues either until an update packet is received with a better metric, the original
route comes back up, or the holddown timer expires.
– The default is 180 seconds.

Route flush timer (240 Second)
– Sets the time between a route becoming invalid and its removal from the routing table (240 seconds).
– Before it’s removed from the table, the router notifies its neighbors of that route’s impending demise.
– The value of the route invalid timer must be less than that of the route flush timer.
– This gives the router enough time to tell its neighbors about the invalid route before the local routing table is updated.

13. How to configure RIPv1?

Router#config t
Router(config)#router rip
Router(config-router)#network 10.0.0.0

14. How to configure RIPv2?

Router(config)#router rip
Router(config-router)#network 10.0.0.0
Router(config-router)#version 2

15. Can we use RIP in inter-network having more than 15 routers?

Yes, If connected with Broadcast Multi Access Network. In BMA (Broadcast Multi Access ) more than two router connected via switch within a same network.

16. What is difference between RIP and RIPng?

RIP is for IPv4 and RIPng for IPv6.

17. What is multicast address of RIPv2?

Multicast Address of RIPv2 is 224.0.0.9

18. How do you stop RIP updates from propagating out an interface on a router?

Holding Down RIP Propagations

There are a few different ways to stop unwanted RIP updates from propagating across your LANs and WANs, and the easiest one is through the passive-interface command. This command prevents RIP update broadcasts from being sent out a specified interface, yet that same interface can still receive RIP updates.

Here’s an example of how to configure a passive-interface on a router using the CLI:
Router#config t
Router(config)#router rip
Router(config-router)#network 192.168.20.0
Router(config-router)#passive-interface serial 0/0
This command will stop RIP updates from being propagated out serial interface 0/0, but serial interface 0/0 can still receive RIP updates.

19. If a RIPv2 router advertise it’s route, would it be received by all the devices on the network?

Rip v2 is multicast. So the route advertisement would be received only by devices which has Rip v2 enabled. If the advertisement was Rip v1, then it would be received by all devices on the network as Rip v1 is broadcast.

20. How can a Rip route advertisement be blocked on a specific interface?

By using the passive interface command.

21. If a static route and a RIP learned route are available on a router which entry would be chosen by the router to forward the packet?

Static route would be chosen since it has lower administrative distance than Rip

22. Can a subnet mask information be stored in a RIPv1 packet?

Rip v1 is a classfull routing protocol. It does not understand classless concepts like Subnets. So it is not possible

23. Is a subnet mask field available in a RIPv2 packet?

Ripv2 is classless routing protocol. A ripv2 packet has a field to include the subnet mask information.

24. How can we manipulate metrics in RIP?

We can manipulate metrics in RIP through the Offset-Lists.

25. What is Offset-List?

– An offset list is the process of Traffic Engineering.
– This technique used for increasing incoming and outgoing metrics to routes learned via EIGRP or RIP.
– The offset value is added to the routing metric.
– An offset list that specifies an interface type and interface number is considered to be an extended list and takes precedence over an offset list that is not extended.
– Therefore, if an entry passes the extended offset list and a normal offset list, the offset of the extended offset list is added to the metric.
– An Offset List Can Be Used to Prefer a Faster Path.

26. Can we use Offset-list in Link State Routing Protocols?

No, Offset lists are only used with distance vector routing protocols.

27. How to configure Offset-List?

To configure an offset to incoming and outgoing metrics to routes learned via EIGRP or RIP, use the offset-list {access-list-number | access-list-name} {in | out} offset [interface-type interface-number]

Access-list-number | access-list-name —Standard access list number or name to be applied. Access list number 0 indicates all access lists. If the offset value is 0, no action is taken. in—Applies the access list to incoming metrics.

Out—Applies the access list to outgoing metrics.

offset—Positive offset to be applied to metrics for networks matching the access list. If the offset is 0, no action is taken.

Interface-type interface-number—(Optional) Interface type and number to which the offset list is applied.

28. What is incoming metrics?

– The incoming metric modifies the cost of an individual segment when a route across the segment is imported into the routing table.
– For example, if you set the incoming metric on the segment to 3, the individual segment cost along the link is changed from 1 to 3.
– The increased cost affects all route calculations through that link. Other routes that were previously excluded because of a high hop count might now be selected into the router’s forwarding table.

29. What is outgoing metrics?

– The outgoing metric modifies the path cost for all the routes advertised out a particular interface.
– Unlike the incoming metric, the outgoing metric modifies the routes that other routers are learning and thereby controls the way they send traffic.

30. What are limitations of RIP?

– The hop count limit in RIP is 15, Without using RMTI, Hop count cannot exceed 15, in the case that it exceeds this limitation, it will be considered invalid or routes will be dropped.
– Most of RIP networks are flat. RIP has no any concept of areas or boundaries in RIP networks (but aggregation is possible).
– RIPv1 does not support VLSM (Variable Length Subnet Masking)
– RIP has slow convergence due to periodic routing update and count to infinity problems.

31. Explain loop avoidance mechanism in RIP.

Maximum Hop Count
– RIP permits a hop count of up to 15, so anything that requires 16 hops is deemed unreachable.
– In other words, after a loop of 15 hops, Network will be considered down.
– Thus, the maximum hop count will control how long it takes for a routing table entry to become invalid or questionable.

Split Horizon
– This reduces incorrect routing information and routing overhead in a distance vector network by enforcing the rule that routing information cannot be sent back in the direction from which it was received.

Route Poisoning
– When Network goes down, Router initiates route poisoning by advertising Network with a hop count of 16, or unreachable (sometimes referred to as infinite).

Hold-downs
– A hold-down prevents regular update messages from reinstating a route that is going up and down (called flapping). Typically, this happens on a serial link that’s losing connectivity and then coming back up..